0
Completed

Disabling or reconfiguring shortcuts

Jarosław Wojtasik 5 years ago • updated by Rhio Kim 4 years ago 5
I don't know if this is currently available.
Right now shortcuts in haroopad are getting in conflict with my system ones.

For example
To get [ ś ] I need ( Alt + s ) but this instead gives me "~~~~"
To get [ ó ] I need ( Alt + o ), which in turn gives "1."

It's kind of a blocker to use haroopad in my native language.
I would be great to have one of those options
  • disable shortcuts
  • make them re-configurable
  • change them to use left Alt instead of the right one.
We need some information:
  1) which Operation system you are using
  2) what type of keyboard
  3) language Input method

It would be helpful  as much as you could give us ;-)

>To get [ ś ] I need ( Alt + s ) but this instead gives me "~~~~"
Strikethrough is assigned to 'CTRL or CMD + Alt + S' as default setting, I guess that it bind with 'Alt + S' on your system.

>To get [ ó ] I need ( Alt + o ), which in turn gives "1."
and it is assigned to 'CTRL or CMD + Alt + O' as default.

We planed to provide custom shortcut system in the next release of v0.11
I think you can solve this problem ;-)
Answer
Under review
Simply put, I'm a victim of [Alt Gr] which is interpreted as [Alt + Ctrl]

Something more about this: here and here

Im using windows 7 with standard  US (QWERTY) keyboard with "Polish programmers" layout
It was fixed long time ago.
Does 0.12.1 works well for you?