0
Fixed

Does not save in W7

Rui Santos 5 years ago • updated by Rhio Kim 4 years ago 14

Having problems saving files on W7 any ideas?

+1

Could you show me more detail information?


- locale you're using

- the full path of file to save.

- any hints from system events log 


I'm unable to provide you more information. I don't get any error. I'm just unable to save.


The behaviour is strange:

- If I try to save a file Untitled: It does not do anything (it seems to save the file, but I don't know were the file is written.

- If i try to 'save as' Nothing happens

- If I exit I get the a dialog asking me if I want to save, I press save but nothing happens the dialog disapears (but the haroopad keeps running) and if I exit I get the same dialog.


If there is a way for me to enable extra debug let me know.

Yes, you have an option.


If Haroopad crashed or encountered logic problems, it writes logs in C:\Users\YOUR-LOGIN-ID\AppData\Local\haroopad\.error.log


It would be a hint for solving your problem. 

Could you show me your HarooPad version ?


You can find it from Perference -> About tab -> Version.


Version 0.4.8.

And I don't have a .error.log


OK I can see haroopad creating the file on the .tmp directory and its updated when I save, but it remains on this directory and I don't get an option of saving it somewhere else.


I have also started to notice that sometimes haroopad does not show the window, but the program is running in the back (I need to kill it on taskmanager)

That's weird.

Please give us time to look into it. We're going to back as soon as possible.



For now, I guess that problem might occur from webkit-node, not from HarooPad logics. We are still on look into it.  


The next release version v0.4.9 will be delivered in a few day soon. Please wait us.



No worries.... waiting.

In the meanwhile I'm already having a look at your code on github. :)

reproduce on v0.9? 

I'm having kind of the same problem. What happens here is that it crashed when I tried to save a file for the first time after it tried to display the folder structure. It restored the document when i started it again but will crash every time i try to "save" or to "save as". I looked in C:\Users\YOUR-LOGIN-ID\AppData\Local\haroopad\ but was unable to find an error.log file.
Similar problem with Timon Schröder's. My error.log file did not save the crash event. It crashed when saving files or typing Chinese.
Haroopad v0.9.1, Windows 7 x64
fixed it. reproduce?
Works on my Windows 7 System now. Thanks!
Thanks response :-)